From version < 3.1 >
edited by Silvia Macovei
on 2016/03/10 08:39
To version < 4.1 >
edited by Gabriela Anechitoaei
on 2016/12/15 16:31
< >
Change comment: There is no comment for this version

Summary

Details

Page properties
Author
... ... @@ -1,1 +1,1 @@
1 -xwiki:XWiki.SilviaRusu
1 +xwiki:XWiki.ganechitoaei
Content
... ... @@ -1,13 +1,15 @@
1 1  1. Create a test page; for ex. create **test.WebHome**
2 2  1. Edit it in Object mode
3 3  1. Add a **XWiki.UIExtensionClass** object to it
4 -1. Fill in the fields with these values:
5 -(((* Extension Point ID - org.xwiki.platform.panels.Applications
4 +1. Fill in the fields with these values:(((
5 +* Extension Point ID - org.xwiki.platform.panels.Applications
6 6  * Extension ID - platform.panels.testApplication
7 -* Extension Parameters:((({{code}}
7 +* Extension Parameters:(((
8 +{{code}}
8 8  label=Test
9 9  target=test.WebHome
10 10  icon=icon:briefcase
11 -{{/code}})))
12 +{{/code}}
12 12  )))
14 +)))
13 13  1. Click "Save & View"
QA.TestClass[0]
Automated
... ... @@ -1,1 +1,1 @@
1 -0
1 +no
User Type
... ... @@ -1,1 +1,1 @@
1 -value1
1 +admin

Home Other Tests Home Run Test

Steps to reproduce

  1. Create a test page; for ex. create test
  2. Edit it in Object mode
  3. Add a XWiki.UIExtensionClass object to it
  4. Fill in the fields with these values:
    • Extension Point ID - org.xwiki.platform.panels.Applications
    • Extension ID - platform.panels.testApplication
    • Extension Parameters:
      label=Test
      target=test.WebHome
      icon=icon:briefcase
  5. Click "Save & View"

Expected results

You have an entry inside the Applications panel labeled Test, having a briefcase icon and pointing to "test.WebHome".

Automated

0

No

Results

per page of Page
Tested By Tested On Jira Issue
The environment prevents the table from loading data.
 
Page

Get Connected